[Oberon] Re (2): Re (2): ISO image for A2 installer.

Treutwein Bernhard Bernhard.Treutwein at Verwaltung.Uni-Muenchen.DE
Tue Feb 12 13:00:15 CET 2019

>> About three years ago instructions here worked.  Haven't tried since.
>> http://www.ocp.inf.ethz.ch/wiki/Development/Builds
>CCing Bernhard for reference.

hmm, yes, I created the images at sourceforge but I was unable to build
newer ones since quite some time and did not get any feedback from 
ETHZ about the problems I encountered since the last ISO available there.

Some news since http://lists.inf.ethz.ch/pipermail/oberon/2018/012608.html
and http://lists.inf.ethz.ch/pipermail/oberon/2018/012611.html follow below:

Current SVN status is 8683 dated 2019-01-11 15:24:01 
see also: https://svn.inf.ethz.ch/svn/lecturers/a2/trunk/ 

I am able to start it in my Debian based Q4OS 64bit (Dual Athlon, Trinity Desktop qt3 based), 
currently the mouse behavior is contra-intuitive so am not able to open Build.Tool in the IDE and
therefore far from reproducing the last errors I encountered in December, where the result
of (excerpt from Build.Tool) the following command 

Linker.Link \P../Test/ \.Obx ../Test/IDE.Bin 0100000H 1000H Kernel Traps
	ATADisks DiskVolumes DiskFS Loader BootConsole ~

resulted in the following error message:

\P../Test/.Gof: error: failed to open file
System.DoCommands: Command: 'Linker.Link', parameters: '\P../Test/ \.Obx ../Test/IDE.Bin 0100000H 1000H Kernel Traps
ATADisks DiskVolumes DiskFS Loader BootConsole' failed: Command not successful (res: 3902)

I speculated that this error is due to some changes in parameter handling, and sent a
message to Felix Friedrich, but I did not get any response from him.

So I am a bit lost currently. 

More information about the Oberon mailing list