[Oberon] Assumed issue in the Lola-2 compiler

Paul Reed paulreed at paddedcell.com
Sat Apr 13 01:42:56 CEST 2019

Hi R.,

> Both Lola-2 compilers - the one created with voc and also my C++
> version - produce exactly the same output... Both generated file
> sets show the wrong type "???" in some
> declarations; see e.g. RISC5Top.v lines 21 to 26.

Good catch!  Thanks!  I think at the very least, the line

             IF (clock IS LSB.Object) & (clock(LSB.Object).name = "clk") 
THEN kind := 1; clock := NIL END ;

should have been removed from procedure LSC.Unit0 at the same time that 
this implicit clk was deprecated elsewhere, last year.  I'll look into 
it further and report back.  Apologies!

I tried to compile Lolac on macos, but the tools declined due to the 
deprecation of x86 in favour of x64.  Why is the Makefile trying to make 
a 32-bit binary?

I tried again on a VM running Centos 7, Linux (kernel) 3.10.0, g++ (GCC) 
4.8.5 20150623, and it built, but when run, e.g.

   $ ./Lolac RISC5Top.Lola

it creates no output that I can find.  What am I missing?


More information about the Oberon mailing list