[Oberon] A2 Repository (was: Mail.FindObj)

Michael Schierl schierlm at gmx.de
Wed Jun 5 22:56:24 CEST 2019

Hello Bernhard,

Am 04.06.2019 um 08:11 schrieb Treutwein Bernhard:
> thanks for the pointer to the metacore repo for A2.
> Just looking at:
> https://github.com/metacore/A2OS/commit/2353b6eb64256dfa1373126ba209bb417401ff81#diff-1551273f7b02a0d3f43608086d201c14
> gives us the important hint how to change the Linker.Link statement in
> Build.Tool for the Bios32 platform,

Yes, I tried that one, and I also tried adding --platform=Bios32 (and
--extension=.Gof), but the resulting images (I used the Virtualbox ones)
do not boot - last line is "OBERON loading" and then the screen remains

Now I also tried again building 2353b6eb64256dfa1373126ba209bb417401ff81
(r8817) but the resulting images (after I increase the partition size
since extracting the .ZIP files always trapped for me) act the same.

> which I guess that it is the new name for native in 32bit.

I guess the "new name" is EFI32 or EFI64 (at least I also found some
places referencing that), but I don't want bleeding edge and Bios32
should be enough (especially since VirtualBox's EFI support is not as
mature as its Bios support).

In other words, I guess it was renamed as there was some support for
(U)EFI booting added.



More information about the Oberon mailing list