[Barrelfish-users] SPLASH2 error in the latest release

Georgios Varisteas yorgos at kth.se
Thu Apr 14 18:06:42 CEST 2011


I'm sorry to revisit this subject but for me SPLASH2 is still not working. I can't apply the patches submitted by Simon Peter in a previous email. If I've understood it correctly, they are to replace the patches given with barrelfish in folders usr/splash2/{barnes,radiocity} respectively. However, doing so gives me only FAILED messages. The process I follow is just like in the readme; by the way, the splash2 sources I use worked with a previous snapshot.

Unpack splash2.tar.gz
Apply splash2-modified.patch
cd /path-to/barrelfish/usr/splash2
SPLASH2_PATH=path-to-modified-splash2-tree ./runme.sh
all FAILED (omitted as of no consequence)

Trying to manually debug the problem I found out that the line numbers in the patches are off. Just by adding newlines at the beginning of each source file allows many (but not all) hunks to succeed!

Obviously I'm doing something wrong since  Waqaas reported that the new patches worked for him. Any clues? Thanks in advance.

Best regards,
Georgios Varisteas

From: Waqaas Munawar [munawar at ira.uka.de]
Sent: Friday, March 04, 2011 4:22 PM
To: C K Kashyap; barrelfish-users at lists.inf.ethz.ch
Subject: Re: [Barrelfish-users] compilation error in the latest release

On 04/03/11 05:14, C K Kashyap wrote:
On Thu, Mar 3, 2011 at 7:49 PM, Waqaas Munawar <munawar at ira.uka.de<mailto:munawar at ira.uka.de>> wrote:
Thanks Simon,
These patches work.
For what its worth, here are the steps that i followed to get the barrelfish running in qemu.

1. Downloaded ubuntu-10.04.2-desktop-i386.iso
2. Made a VMware virtual machine out of this.
3. updated it (sudo apt-get upate and applied the updates)
4. edited /etc/apt/source.list and replaced all instances of "lucid" with "natty" and then updated (sudo apt-get update)
5. installed libghc-ghc6-paths-dev (which should ideally pull ghc6 alongwith)
6. reverted /etc/apt/source.list by replacing all instances of "natty" with "lucid" and update (sudo apt-get update)
7. installed zlib1g-dev (sudo apt-get install zlib1g-dev)
8. installed cabal (sudo apt-get install cabal-install)
9. update cabal ("cabal update", followed by "cabal install cabal-install")
10. installed qemu (sudo apt-get install qemu)
11. followed the README in barrelfish/usr/splash2/ with new patches
12. then followed the README in barrelfish/

the tools that I used were:
ghc  version 6.12.3
GNU ld (GNU Binutils for Ubuntu) 2.20.1-system.20100303
gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3

The size of the VMimage is 3.9GB. Perhaps some bytes can be saved by compression but we will certainly not be able to host it. Is anyone else interested in doing that ?

Hey Waqaas ... you enumerated steps itself seems very useful - it's sort of guaranteed to work ... I'm gonna give it a shot.
I am guessing, you built the 32 bit barrelfish?

Sorry for delay, somehow I missed your mail earlier.
Well I am not sure about barrelfish, but I built it on a 32 bit machine. The target architecture for barrelfish was x86_64.

Secondly after compression the VM Image occupies 1.4GB.


More information about the Barrelfish-users mailing list