[Oberon] Controlling Aos with VNC: a small report

Patrik Reali reali at acm.org
Sat Apr 26 00:25:17 CEST 2003

I just installed a 5 year old machine (dual P-II 400MHz) with Aos. The VNC
server is installed at startup in AosConfig.XML. The machine has no screen,
no mouse, and is remotely controlled; it sits in my closet so that no space
is used and the constant noise disturbs nobody. Everything is connected
through a 100Mbit/s local network.

This configuration works nicely and I can control the machine from any VNC
client. Now. But getting there wasn't trivial.

First: to do the same, add the following lines to your AosConfig.xml
<Section name="Autostart">
    <Setting value="WMVNCView.Install Aos password 5901 0 0 1024 768" />

* Aos is the name appearing on the VNC window
* password is.... guess....
* 5901 is the TCP port
* 0 0 is the base of the VNC window in the virtual display space of Aos
* 1024 768 is the size of the VNC window

usually an Autostart section is already present in you AosConfig.xml

Also ensure that Autostart.Run is called at boot-time by adding
to your system's configuration strings, where X is the smallest 1-digit
number still not already used.

After the nice part, the troublesome part.

When I installed it, I used the Aos VNC Viewer from another machine to check
that the server did start. It worked, but the refresh did not work well, and
made it unpractical for use.

I installed the latest VNC for Windows (3.3.7) on two other computers on the
same LAN:
* on the laptop (700 MHz), the connection was closed by the server even
before asking for the password. This happened also with the 3.3.3 version.
* on the desktop (233 MHz) it worked for a while, then froze (in fact, the
Aos server did disappear from the net, had to reboot the machine because
without screen nor trace I had no clue what was wrong).

According to two local gurus, my laptop is sending the requests to the VNC
server too fast, same to a lesser degree for the desktop. The only solution
to this is to use a slower machine or to trottle the network: I first
configured my laptop for 10Mbit without duplex. The situation improved, but
I still had a frozen system after a while. Then I did the same with the Aos
machine: I booted pressing the left shit key to get into configuration's
manager, added
3C90xMedia="1"  (Base-10T mode)
3C90xDuplex="1"    (Simplex mode)
with "W" I wrote the configuration back to the boot partition (in this case
a floppy), then with "c" booted Aos.

Now I can work with Aos through VNC without problems with vnc 3.3.7 (vnc
3.3.3 still doesn't work)


Patrik Reali

More information about the Oberon mailing list