AW: [Oberon] Booting Bluebottle on Celeron D 326

Stauber Sven Philipp staubesv at
Tue Jan 3 15:20:11 CET 2006

>I also tried the setting "MaxProcs=1" with no success.
Try to set MaxProcs to a negative number - this will simulate a single processor machine and therefore skip some code in AosProcessors.Mod.
>Do others report successful operation of the Celeron D 326 processor ?
Not on Celeron D, but my Pentium D works fine. Should actually be almost the same processor.
Does the current release (not the crazy fresh) boot on that machine?
Sven Stauber


Von: oberon-bounces at im Auftrag von Patrick.Hunziker at
Gesendet: Di 27.12.2005 14:12
An: oberon at
Betreff: [Oberon] Booting Bluebottle on Celeron D 326

I tried to boot Bluebottle 19.12.05 from CD on a recent Pentium System (Shuttle
Celeron D 326 (2.53MHz), 256MB RAM, Chipset SiS 661FX / 963L

There is a problem early after "Bluebottle loading":
I am able to change settings in the BBL0: mode if I need.
I used TraceMode=1 over a serial cable, to locate the problem.
Now I see, over the serial connection:
"Aos 19.12.05",
then booting fails, the machines goes on to reboot again from zero. Same with
On other machines, I see "Processor ..." etc. now.
>From the Output on the serial line, it appears that the problem is in
AosBoot.Mod, maybe in recognizing the processor ?
I also tried the setting "MaxProcs=1" with no success.
I have also tried to eliminate Boot actions from "Boot5" back to "Boot1" back to
"Boot", and have tried to boot without accessing the video driver by setting
"Init=" and TraceMode=4 with no avail- the problem appears to occur earlier on
in the boot process.
It does not appear to be a problem of the display driver as far as I see. A try
to circumvent the problem by booting from USB did not succeed either.

Where might the problem be ?
Do others report successful operation of the Celeron D 326 processor ?

(BTW: -adding the file AosSetup.Text to the WM Menu might be helpful for others)
(BTW2: there is an inconsistency in the syntax of TraceMem= between
AosSetup.Text: TraceMem=0B8000H,80,25 and
Boot CD: TraceMem=0B8000H,2,80,25 : bug or feature ?)

Thanks for help

This message was sent using IMP, the Internet Messaging Program.

Oberon at mailing list for ETH Oberon and related systems

More information about the Oberon mailing list