[Oberon] Re (2): Re (2): LOOP conversion

peter at easthope.ca peter at easthope.ca
Wed Jan 6 22:12:23 CET 2021

From:	August Karlstrom <fusionfile at gmail.com>
Date:	Wed, 6 Jan 2021 21:13:15 +0100
> We should also note that this is only the first step to make the program 
> compile. 

I agree August.  I've been using A2 since it was first released.  I 
appreciate the need for testing and auditing of all code.

> If comprehensibility is the goal the variables named 
> "continue", "done" etc. should ideally be replaced with something more 
> descriptive and specific. When skimming through the program a loop like
> 	continue := TRUE;
> 	WHILE continue DO
> 		...
> 	END;
> is not very informative. After the loop we know that `continue' is false 
> but what does that imply?

Yes.  Any suggestion for a name better than continue is welcome.  

By the way, I left extra comments to facilitate comparison to the LOOP 

Another criticism of my conversion: the new Menu procedure occupies 
about 1.3 screen height. Very difficult to read and understand.  I 
might find a way to factor segments out as subroutines.

The overall objective is to find a way to bring an older system such as ETH 
Oberon or V4 into 2021.

Regards,                  ... P. L.

Tel: +1 604 670 0140            Bcc: peter at easthope. ca

More information about the Oberon mailing list