[Oberon] Re (2): A2 WebBrowser.

Chris Burrows cfbsoftware at gmail.com
Wed Dec 22 05:48:34 CET 2021

On Tue, Dec 21, 2021 at 5:03 AM <peter at easthope.ca> wrote:

> From:   Liam Proven <lproven at gmail.com>
> Date:   Mon, 20 Dec 2021 18:50:34 +0100
> > You need to try non-HTTPS sites.
> Certainly.  Firefox and Dillo open a trivial local page.
> file:///home/peter/a.html
> The A2 WebBrowser freezes at "Loading...".  The failure is lower level
> than TLS.
> You have UnixA2 (LinuxA2)?  A2 on a bare PC?  Which revision of A2?
> 32 bit machine?  64 bit?
> Thanks,                                 ... P.L.

I tried browsing some local pages on Windows 10 using A2/WinAos. Apart from
a suspected problem with hyphens in folder names, that worked OK. I see
error and trace messages in the Kernel Log viewer, do you? For example:

ContentLoader: Loading: file://D:/WebAstrobe/Cortex-M3/default.htm
file not found: file://D:/WebAstrobe/Cortex-M3/default.htm
Not found: file://D:/WebAstrobe/Cortex-M3/default.htm
ContentLoader: Loading done.
ContentLoader: Loading: file://D:/WebAstrobe/CPIde/matrix.htm
---Loading HTMLPanel. Url: file://D:/WebAstrobe/CPIde/matrix.htm
---Parsing file://D:/WebAstrobe/CPIde/matrix.htm
---Parsing done.

Chris Burrows

CFB Software
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.inf.ethz.ch/pipermail/oberon/attachments/20211222/cc9f9696/attachment.html>

More information about the Oberon mailing list