[Oberon] A2 Repository (was: Mail.FindObj)

Michael Schierl schierlm at gmx.de
Sun Jun 2 13:48:41 CEST 2019

Am 30.05.2019 um 17:43 schrieb Liam Proven:

> So the source is out there. That's good.
> Has anyone actually managed to build it?

Any particular platform?

I tried for the first time to build UnixAos (Linux64), and I used
(corresponds to SVN revision 9003) and I believe I managed to rebuild
everything (all the modules compiled by Release.Build, as well as the
core object file), and it still starts up. :)

The hardest part was to find the correct Linker.Link line in the dozens
of .Tool, .Text and .Mod files that contain Linker.Link lines.
"Fortunately", some of them used an incorrect syntax (when compared to
Linker.Mod), so all the lines containing \P (instead of --path) or \.
(instead of what?) could be ruled out.

The lines that finally worked for me are the ones at the end of
source/Builds.Tool (not to be confused with Build.Tool or Builder.Tool...)

I then wanted to try linking native A2 (Bios32), but did not find any
Linker.Link line for it that uses the correct syntax, so I stopped as I
assume it would need some more trial&error for me to find the correct
modules to link. Also, testing native would take longer - UnixAOS can be
started and tested quickly.

(If there was a known good revision, one could use "git bisect" to find
the commit that broke it, but probably it will find the commit that
changed the syntax to Linker.Link without updating the documentation...)



More information about the Oberon mailing list