[Barrelfish-users] netd and howto get files into BF/Qemu

Georgios Varisteas yorgos at kth.se
Wed Dec 14 16:10:38 CET 2011

Thanks Pravin, that worked great.

However now I have another problem. On fopen() I get:
Warning: fopen() called with _libc_fopen_func unset

I saw how vfs_init() handles that but i couldn't figure out exactly how my app should set the whole thing up correctly. Is there a tutorial somewhere I've missed? Thanks in advance.

Best regards,
Georgios Varisteas

From: shindepravin at gmail.com [shindepravin at gmail.com] on behalf of Pravin [pravin at inf.ethz.ch]
Sent: Wednesday, December 14, 2011 14:28
To: Georgios Varisteas
Cc: barrelfish-users at lists.inf.ethz.ch
Subject: Re: [Barrelfish-users] netd and howto get files into BF/Qemu

Hi Georgios,

I have created a page on public wiki about how to use Barrelfish
inside qemu with networking.  I hope this will help in clearing some
confusion about it's usage.
In summary, you will have to enable "support_qemu_networking" inside
<your_build_dir>/hake/Config.hs, and you will have to pass correct
cardname to netd in menu.lst.

Coming back to the output you are getting, it seems that either netd
or your application is waiting for e1000 driver instead of rtl8029
driver.  Currently only rtl8029 driver works with qemu.  You can
specify the cardname for netd with boot time parameter in menu.lst.

If driver and netd is working for you, then you should be able to get
IP address for Barrelfish.  If you are able to get an IP address then
it is good enough test to see if networking is up or not.   Let me
know if you have already reached this point.

Using NFS should work fine if you want to get some files inside
Barrelfish running on QEMU.

I hope this helps.  Let me know if you still have problems.


On Wed, Dec 14, 2011 at 13:20, Georgios Varisteas <yorgos at kth.se> wrote:
> Hi,
> I tried using the network in qemu, but when I try to mount an nfs share BF just freezes on:
> "chips: client waiting for e1000_CTRL"
> while I have successfully connected through the rtl8029 card. Nothing related to e1000 is loaded.
> I only need this in order to have simple files added to the ramfs image. Is there any other way? I only care to input files and not necessarily output. I thought of adding them to the skb archive but I was afraid that it could mess other stuff up. Ideally GRUB would do that, like with binaries, but I do not know how...
> Best regards,
> Georgios Varisteas
> _______________________________________________
> Barrelfish-users mailing list
> Barrelfish-users at lists.inf.ethz.ch
> https://lists.inf.ethz.ch/mailman/listinfo/barrelfish-users

More information about the Barrelfish-users mailing list