[Barrelfish-users] GRUB boot loop and virtualBox freeze.

Georgios Varisteas yorgos at kth.se
Fri Jul 13 11:34:25 CEST 2012

Hi again,

I was just a bit to fast in sending that email. One thing that did work was  completely removing the build folder and rebuilding from scratch. Whatever it was in that last update must have had some backwards incompatibility of some shorts. Initially I did remove the depends and run hake again. Maybe it was just some hake configuration mismatch.


From: Georgios Varisteas [yorgos at kth.se]
Sent: Friday, July 13, 2012 11:22
To: barrelfish-users at lists.inf.ethz.ch
Subject: [Barrelfish-users] GRUB boot loop and virtualBox freeze.

Hi all,

A few days ago I updated to the latest revision and tried booting with Qemu; it ends up in an infinite boot loop in GRUB. When all modules are loaded, the VM restarts. On VirtualBox (using hdd, not tftpd) the VM simply freezes after GRUB loads all modules. I've tested this on several machines (all running Gentoo though), with a fresh clone of the repo, different versions of Qemu, every time the same result.

Anyone else experiencing the same situation? Any hints on a solution or workaround?

My last thought is that it's Gentoo's fault and will try with Ubuntu...


Barrelfish-users mailing list
Barrelfish-users at lists.inf.ethz.ch

More information about the Barrelfish-users mailing list