[Oberon] Unix Oberon and Redhat 9.0

Jacques Eloff eloff at cs.sun.ac.za
Thu Jun 12 00:36:53 CEST 2003


I've recently upgraded from Redhat 7.0 to 9.0. I've been using Linux
Oberon, release 2.3.7b under RH7.0, but it does not seem to work
under RH9.0. I've tried relase 2.3.8a as well, but it gives the same problems.

The system runs fine for while and then the main thread just stops. The
other threads are still active (I checked this with "ps -le"). There's no
segmentation faults or anything strange. Oberon just reports that it
has exited, something like "[1]+ Stopped oberon" or "[2]+ Stopped oberon".
The X-window containing Oberon is not even closed when this happens.
Has anyone had similar problems? I've run the testgcc programs that
came with Oberon and everything seems happy with the way the system
is set up. I've also tried using the old glibc5.0 instead of glibc6.0 
binaries, but the results are always the same.

I've also tried using the latest LNO with my AOS partition, but LNO also 
refused to execute. According to the oberon.log file, the partition could be 
accessed, but then it traps with a page fault and drops me back to my xterm.

Jacques Eloff
Department of Computer Science
University of Stellenbosch

More information about the Oberon mailing list