[Oberon] Unix Oberon and Redhat 9.0

Guenter Feldmann fld at informatik.uni-bremen.de
Thu Jun 12 12:19:07 CEST 2003

On Thursday 12 June 2003 00:36, Jacques Eloff wrote:
> Hi
> I've recently upgraded from Redhat 7.0 to 9.0. I've been using Linux
> Oberon, release 2.3.7b under RH7.0, but it does not seem to work
> under RH9.0. I've tried relase 2.3.8a as well, but it gives the same
> problems.
> The system runs fine for while and then the main thread just stops. The
> other threads are still active (I checked this with "ps -le"). There's no
> segmentation faults or anything strange. Oberon just reports that it
> has exited, something like "[1]+ Stopped oberon" or "[2]+ Stopped oberon".
> The X-window containing Oberon is not even closed when this happens.
> Has anyone had similar problems? I've run the testgcc programs that
> came with Oberon and everything seems happy with the way the system
> is set up. I've also tried using the old glibc5.0 instead of glibc6.0
> binaries, but the results are always the same.

Hi Jacques

 I havn't tried Oberon on Redhat9 so far. But what you write looks like 
the threads behaviour has changed in Redhat 9. If you have the sources
on hand you could try to create a new linux.oberon binary with the
threads extension disabled. The Oberon system does not depend on 

	cd src/x86/Unix
	gcc -o linux.oberon   -DLINUX   oberon.c -ldl -lm

 Please let me know if Oberon workes with that boot loader.

-- Guenter

More information about the Oberon mailing list