[Oberon] Unix Oberon and Redhat 9.0

eas-lab at absamail.co.za eas-lab at absamail.co.za
Thu Jun 12 10:11:14 CEST 2003

Jacques Eloff wrote:

> I've recently upgraded from Redhat 7.0 to 9.0. I've been using Linux
> Oberon, release 2.3.7b under RH7.0, but it does not seem to work
> under RH9.0. I've tried relase 2.3.8a as well, but it gives the same problems.
> The system runs fine for while and then the main thread just stops. The
> other threads are still active (I checked this with "ps -le"). There's no
> segmentation faults or anything strange. Oberon just reports that it
> has exited, something like "[1]+ Stopped oberon" or "[2]+ Stopped oberon".
> The X-window containing Oberon is not even closed when this happens.
> Has anyone had similar problems? I've run the testgcc programs that
> came with Oberon and everything seems happy with the way the system
> is set up. I've also tried using the old glibc5.0 instead of glibc6.0 
> binaries, but the results are always the same.
> I've also tried using the latest LNO with my AOS partition, but LNO also 
> refused to execute. According to the oberon.log file, the partition could be 
> accessed, but then it traps with a page fault and drops me back to my xterm.

I've still got the mental images of all the bug discussion in the *linux* 
NewsGroups re. RH8.0.

We appreciate those who sacrifice themselves on the bleeding edge.

BTW. can you list (or point to docs. re.) significant  improvements
of LNO 2.3.7, 2.3.8 over 2.3.6 ?

-- Chris Glur.

More information about the Oberon mailing list