[Oberon] Unix Oberon and Redhat 9.0

Necati Ecevit fnecati at gyte.edu.tr
Thu Jun 12 13:56:57 CEST 2003

Jacques Eloff wrote:

> I've recently upgraded from Redhat 7.0 to 9.0. I've been using Linux
> Oberon, release 2.3.7b under RH7.0, but it does not seem to work
> under RH9.0. I've tried relase 2.3.8a as well, but it gives the same problems.
> The system runs fine for while and then the main thread just stops. The
> other threads are still active (I checked this with "ps -le"). There's no
> segmentation faults or anything strange. Oberon just reports that it
> has exited, something like "[1]+ Stopped oberon" or "[2]+ Stopped oberon".
> The X-window containing Oberon is not even closed when this happens.
> Has anyone had similar problems? 

Yes, I had the same problem with Linux Oberon 2.3.8a release on RH9.0.
I solved the problem by recompiling the oberon.c with
disabling the thread support.

It is written in src/x86/Unix/oberon.c,
  without Threads support:
  * Linux:	gcc -o linux.oberon   -DLINUX   oberon.c -ldl -lm

Then, I replaced this new linux.oberon file with the previous one.


More information about the Oberon mailing list