[Oberon] Bluebottle under VM

AVas jesusv at bk.ru
Sat May 6 16:29:32 CEST 2006

Could please someone tell me, why i cant run bluebottle crazy fresh
release 7.04.06 under virtual machine?
On my Red Hat EL i tried qemu 0.8 and bochs 2.2.6 and parallels
workstation 2.1...
under all of them aoscd begins to load, sets video mode and stops with
an empty black screen.
I tried to set various video modes manualy... it doesn't help.
Under VMware Workstation 5.0 and VMWare player bluebottle starts
perfectly, but works very,very,very slow.
And what is realy funny that on windows xp under VMWare workstation 4
all starts and works fine. WTF?
I don't able to try VMWare 4 on Linux...
In native mode it all works fine too, except it don't detects some of
hardware, but that was what i expected.
There were the only NIC working with bluebottle i was able to find. It's
3com 3c905b etherlink III combo.
AosPCITools.Scan showed me that it is "3c905b deluxe etherlink
10/100/bnc [cyclone]" vendor/device 10b79058.
After some searching and trying i add the following:
in AosDriverDatabase.XML
<device id="9058" name="Model90xC" ...>
in Aos3Com90x.Mod
    in Install
if set to auto nic tries to work via coaxial...
After that bluebottle detected nic and network become available.

Because i can't use second pc for a long time it'll be much better for
me to run bluebottle under any VM software. I'll be appreciate for any help.


More information about the Oberon mailing list