[Oberon] Bluebottle under VM

Thomas Frey thomas.frey at alumni.ethz.ch
Wed May 10 19:48:21 CEST 2006

Since qemu should really be HW and OS independant, I checked it with
one of the latest bluebottle images. And indeed it fails. The problem
is the new ATA driver.
A workaround with setting the boot option
helps. But since the qemu BIOS emulation does not waste much time at
startup, it is extremely difficult to activate the just poping up
emulator window and then holding down the SHIFT key to go into the
boot options before the booting already started (i have to try about
ten times to catch it once on my setup).

Maybe there can be a fix for this in the new ATA driver on the release CD ?

Once the system is installed on a virtual harddisk with this
additional setting, the problem is solved. (Activating the DMA with
the new ATA options could speed up the HD transfers)

Btw. I noticed VMWare 5 to be extremely slow, too and hence stick to
version 4 because this works reasonably. I dont know what was changed
from VMWare 4-5.

Another virtualization SW that can run Bluebottle can be found on
parallels.com but there the Acceleration has to be set to lowest
(probably = most compatible).

MS VirtualPC can run Bb only on Macintosh (probably non-intel only ?),
on Intel they got the emulation of the timer chip wrong.


On 5/10/06, w <jmd at antsinfields.de> wrote:
> Hi Andrew
> Sorry, this mail will not solve your problem.
> But,  since I have the same problems with gentoo und vmware 5.x, I want
> to stress the importance of your questions.
> Bluebottle + vmware 5.x + gentoo   is very, very,very slow on my normal
> computer and my IBM-T43. It's just impossible to work with.
> (Bluebottle under Quemu und boch doesn't work on my computers too.)
> So, I think the problem depends not our hardware.
> I'll be appreciate for any help.
> Thanks
> Wolfgang
> AVas wrote:
> > Could please someone tell me, why i cant run bluebottle crazy fresh
> > release 7.04.06 under virtual machine?
> > On my Red Hat EL i tried qemu 0.8 and bochs 2.2.6 and parallels
> > workstation 2.1...
> > under all of them aoscd begins to load, sets video mode and stops with
> > an empty black screen.
> > I tried to set various video modes manualy... it doesn't help.
> > Under VMware Workstation 5.0 and VMWare player bluebottle starts
> > perfectly, but works very,very,very slow.
> > And what is realy funny that on windows xp under VMWare workstation 4
> > all starts and works fine. WTF?
> > I don't able to try VMWare 4 on Linux...
> > In native mode it all works fine too, except it don't detects some of
> > hardware, but that was what i expected.
> > There were the only NIC working with bluebottle i was able to find. It's
> > 3com 3c905b etherlink III combo.
> > AosPCITools.Scan showed me that it is "3c905b deluxe etherlink
> > 10/100/bnc [cyclone]" vendor/device 10b79058.
> > After some searching and trying i add the following:
> > in AosDriverDatabase.XML
> > <device id="9058" name="Model90xC" ...>
> > in Aos3Com90x.Mod
> >     in Install
> > ScanPCI(10B7H,9058H,Model90xC,{},100Base-TX);
> > if set to auto nic tries to work via coaxial...
> > After that bluebottle detected nic and network become available.
> >
> > Because i can't use second pc for a long time it'll be much better for
> > me to run bluebottle under any VM software. I'll be appreciate for any help.
> >
> > Andrew.
> > --
> > Oberon at lists.inf.ethz.ch mailing list for ETH Oberon and related systems
> > https://lists.inf.ethz.ch/mailman/listinfo/oberon
> >
> >
> --
> Oberon at lists.inf.ethz.ch mailing list for ETH Oberon and related systems
> https://lists.inf.ethz.ch/mailman/listinfo/oberon

More information about the Oberon mailing list