[Scion] Unable to run SCION after update

Juan A. García-Pardo juagargi at gmail.com
Thu Sep 19 13:01:42 CEST 2019

Hi Siddharth,
We have not yet upgraded the tutorials for everything, only the "updating
SCION" one:
That said, almost all that you are seeing is normal: the configuration TGZ
you get from the Coordinator is very small, because your VM will get the
full configuration from the Coordinator for you. Once you have run `vagrant
up`, you will see the directory /etc/scion contains a `gen` directory
inside. That one will have the full configuration.
Also, the services and tools are now packaged. There is no $SC directory
anymore. Things you can run to check:
- dpkg -l |grep scion  # will list scion packages, hopefully installed in
your system
- systemctl list-dependencies scionlab.target  # list status. In Ubuntu
16.04 there is a systemd bug and the services will be listed twice
- sudo systemctl restart scionlab.target  # restart all SCION services
- ls -l /var/log/scion  # list scion log files
- ls -l /var/lib/scion  # list trust databases, etc
- ls -l /etc/scion  # list scion configuration. The gen folder has the same
morphology as before, but the supervisord files are not used

On the other hand, if you want to not use the packages and go back to the
developer way of doing things, you can briefly read about that also in the
how to update SCION page from SCION tutorials, but basically refers to
stopping systemd for scionlab.target and cloning/building SCION yourself.

The problem with the VPN is not clear at all though. I would like to
investigate a bit more about that. Can you try again? If you still see the
problem the second time you try, we'll investigate further.
Thanks and best regards,

Juan A.

On Wed, Sep 18, 2019 at 10:52 AM Siddharth Mehrotra <the4daspect at gmail.com>

> Hi all,
> I tried to run SCION after update from attachment point with ETHZ-AP as
> downloading new configuration. I'm currently installing inside a VM with
> use of OPENVPN to connect to SCION Lab.
> I observed following scenarios:
> 1) After extracting configuration file from SCION coordination service, the
> contents are reduced to:
> Mode                LastWriteTime         Length Name
> ----                -------------         ------ ----
> d-----       18-09-2019     10:25                .vagrant
> d-----       18-09-2019     10:23                gen
> -a----       13-06-2019     09:25           3618 README.md
> -a----       13-06-2019     09:25           3068 run.sh
> -a----       18-09-2019     10:22           3813
> scion_lab_17-ffaa_1_c32.tar.gz
> -a----       18-09-2019     10:34              0
> ubuntu-xenial-16.04-cloudimg-console.log
> -a----       18-09-2019     10:24           2484 Vagrantfile
> Many SCION services are missing.
> 2) Although I was able to run the VM successfully and SSH to SCION.
> However, it seems the connection to SCION was not successful. The below
> command is after running Vagrant up:
> default: WARNING:WARNING!: VPN could be unready. SCION may fail to start.
>     default: Created symlink from
> /etc/systemd/system/scionlab.target.wants/scion-border-router at 17-ffaa_1_c32-1.service
> to /lib/systemd/system/scion-border-router at .service.
>     default: Created symlink from
> /etc/systemd/system/scionlab.target.wants/scion-certificate-server at 17-ffaa_1_c32-1.service
> to /lib/systemd/system/scion-certificate-server at .service.
>     default: Created symlink from
> /etc/systemd/system/scionlab.target.wants/scion-path-server at 17-ffaa_1_c32-1.service
> to /lib/systemd/system/scion-path-server at .service.
>     default: Created symlink from
> /etc/systemd/system/scionlab.target.wants/scion-beacon-server at 17-ffaa_1_c32-1.service
> to /lib/systemd/system/scion-beacon-server at .service.
>     default: Created symlink from
> /etc/systemd/system/scionlab.target.wants/scion-daemon at 17-ffaa_1_c32.service
> to /lib/systemd/system/scion-daemon at .service.
>     default: Created symlink from
> /etc/systemd/system/scionlab.target.wants/scion-dispatcher.service to
> /lib/systemd/system/scion-dispatcher.service.
>     default: configure time sync
>     default: ntp.service is not a native service, redirecting to
> systemd-sysv-install
>     default: Executing /lib/systemd/systemd-sysv-install enable ntp
>     default: configure unattended upgrades (automatic security upgrades)
>     default: SCIONLab VM ready
> 3) When I am inside the VM and I tried to check the connection I was
> surprised to see this:
> vagrant at scionlab-ffaa-1-c32:~$ checkbeacons
> checkbeacons: command not found
> Also fo this:
> vagrant at scionlab-ffaa-1-c32:~$ tail -f $SC/logs/bs*.DEBUG
> tail: cannot open '/logs/bs*.DEBUG' for reading: No such file or directory
> tail: no files remaining
> 4)Memory Test:
> vagrant at scionlab-ffaa-1-c32:~$ df -h
> Filesystem      Size  Used Avail Use% Mounted on
> udev            992M     0  992M   0% /dev
> tmpfs           200M  3.1M  197M   2% /run
> /dev/sda1       9.7G  1.4G  8.3G  14% /
> tmpfs          1000M     0 1000M   0% /dev/shm
> tmpfs           5.0M     0  5.0M   0% /run/lock
> tmpfs          1000M     0 1000M   0% /sys/fs/cgroup
> vagrant         136G   73G   64G  54% /vagrant
> tmpfs           200M     0  200M   0% /run/user/1000
> 5) tun0 not found after performing ip a command.
> PS: I am using Oracle Virtual Box 6.0 , Is it the compatibility issue ?
> PS: I was able to run SCION successfully before the update with same
> Virtual Box version and vagrant also.
> Please look into this issue.
> Thanks,
> Sid
> _______________________________________________
> Scion mailing list
> Scion at lists.inf.ethz.ch
> https://lists.inf.ethz.ch/mailman/listinfo/scion

More information about the Scion mailing list